Blender location glitch

Hi!
I came to this forum so that I could try and ask a question about getting NI mate to work in blender. Everything is working great up to a point: The kinect 360 is tracking my skeleton on Mac through the NI mate portal, however when I click start on the blender add on, the location of the generated empty on the x axis suddenly jumps to an increasingly high location (e.g.15364m). this only happens when the sensor is turned on. I have tried deleting and reinstalling all relevant programs, and messing with various settings but I can’t seem to get it to work. Any help would be enormously appreciated.
Thanks,
Jamie

As an update, I have tried to install all relevant programs on a different Mac and I got the exact same issue. I have also tried in different versions of blender. I can’t get NI mate to connect to my kinect on windows computers and Mac is my first preference anyway.

Hello!

Could you check if this happens when you playback the example clip as opposed to outputting live sensor data? This could allow isolating if the issue happens due to the live tracking data or something else. To do this, go on the sensor page, click the button labeled “live”, and then choose the example clip. You can then put the clip playbacking and enable the skeleton tracker to output the data just like with real sensor.

Thank you so much for your help!
I did as you requested and the same location issue occurred. The location glitch only occurs when the example clip is playing, not when it is paused.
I really appreciate you helping me, this is fantastic service.

  • Is it only one of the generated empties that jumps far away or all of them?
  • Which skeleton tracker output mode are you using? (basic, basic + orientation, orientation…)
  • Does it happen if you change the port used for the OSC communication?`You need to change this in both NI mate and Blender.

It is all of the empties, (or spheres or cubes), the NI_mate_sync object jumps to an increasingly high x value which continues to increase by about 10000m per second for only the time that the sensor is active and blender is connected to the sensor. (see attached image).
Screen Shot 2020-09-28 at 4.20.05 pm
I am unsure how to see which skeleton tracker output mode I am using, would you mind explaining where that is?
I have tried changing the port and that has not fixed the issue.
Thanks,
Jamie

The relevant documentation is here: Documentation: Skeleton tracking

The “mode” button on the screenshot is below the “Joint OSC mapping” header.

This sounds like a bug in the Blender plugin. Do you have the “add rotations” checked?