Delicode NI mate Tutorials: Blender Motion Capture Basics

Uploaded on Jan 31, 2012
This tutorial by Janne Karhu explains how you can use NI mate for basic motion capture within Blender. To download the software and examples, visit the product web pages at http://www.ni-mate.com.

hi, there is a guide for the new version of Ni-mate for mac? moreover i have follow this guide but the bone model move only x-y-z and move only torso… why? thanks!! :wink:

I already installed the NI delicode mate , but can also be connected blum WITH blander , how the trick
please help me

I’m afraid I didn’t fully understand your question. Could you explain your problem with a bit more details?

I’m having some trouble to set up Blender and NI Mate on OSX, The interface on the tutorial covers only the windows version of the software. How can you set up the names of the output for the bones? That is shown on this moment of the video:

There is no OSC output on the mac OSX version of NI Mate, only MIDI:

It would really help me if anyone knows how to fix this, without this I can’t set it up on the Game Engine… :sweat:

On the side: the “feature” that new users can’t post more than one image per post is kinda lame, that’s why I glued the two images in one…

You don’t need OSC input for this as it’s used for remotely controlling NI Mate (ie. sending an OSC message to tell NI mate to shut down). OSC output is enabled by either clicking the checkbox next to one of the components (skeleton tracker, controller tracker, etc) or by clicking the button on the component’s page (you need to expand the page tree under “OpenNI1” in the page tree at the left side of the UI).

The bones are named on the Skeleton Tracker page. You can get more details from our documentation.

1 Like

Thank you very much Jesse! Very fast reply! :grinning:

[SOLVED]
So I named every object on the scene the same as the output of the skeleton, and each cube is running the code on the right:

but when I run the game, the plane works (shows the feed from NI Mate), but the cubes just shrink (because the code shinks them if they dont move, I got this code from one of the examples).

if this is called using all object in the scene, as is:

def set_GE_location(objects, ob_name, vec, originals):
    ob = objects.get(ob_name)
    
    if ob != None:
        ob.localPosition = 10*vec
        ob['time'] = -1

The camera calls this:

def updateGE(controller):
    import bge

    if hasattr(bge.logic, 'DelicodeNImate') == False:
        setupGE(controller.owner)

    bge.logic.DelicodeNImate.run(bge.logic.getCurrentScene().objects, set_GE_location, set_GE_rotation)

Why they don’t move? :pensive:

Here is a lnk to the .blend file: FILE

I took a quick look at it and there are a lot of errors in the Blender console upon launching the game engine with that .blend file. Since you already marked this as solved, I won’t look more into this. What is it that you had to change?

I don’t know exactly what, I restarted the computer, maybe it was that… Thnak you by the way!

You can see the full details of mocap using kinect at 6eyestudios.blogspot.in