How do I get NI Mate to record at exactly 30 fps?


#1

I’ve been using the Asus Xtion Pro Live sensor with NI Mate, and it has been recording my actions at around 20-25 fps. How do I get it to be exactly 30 fps? It is set to 30 fps, but it says 20-25 once it’s live.


#2

This could be either a problem with the arriving USB data, CPU usage being too high, or GPU usage being too high. The USB problem is harder, but generally you can improve this by not having anything bandwidth intensive connected to your computer apart from the sensor.

Some ideas to get the FPS up:

  • Disable outgoing skeleton tracker, controller tracker, trigger data and uncheck all the boxes on the Log page. The OSC processing is rather CPU intensive due to every OSC message being evaluated as a script.
  • Disable other non-NI mate CPU intensive applications
  • Use “GPU Texture Transfer” in the NI mate preferences if it works

What kind of hardware are you using?


#3

Thanks for the response. I tried all of these options, but it didn’t speed up the fps. I’m probably not using the best equipment. I’ve been using an Inspirion 15 3000 series laptop. I’ve been transferring the skeleton tracking data into Blender, so the laptop probably doesn’t have the juice to keep up with both applications, or even NI-Mate alone.

I’ll give it a shot on my desktop PC.


#4

Tried it on my desktop, and everything is working great! Thanks for the help. @Jesse


#5

At least a while back Blender’s keyframe recording had some serious performance issues. If you recorded keyframes in Blender then it’s possible this was the real performance sink.


#6

I believe it was a little of both NI Mate and Blender being too much for my laptop. I did try NI Mate alone, and my laptop wouldn’t allow it to record full 30 fps. But like I said, it’s all working great on my desktop PC.