How do I start Ni Mate


Silly question, I suppose, but I can’t figure it out.

I am running lubuntu 17.10.
Downloaded and placed in /src/nimate/ Delicode-NI-mate_1.20-ubuntu_1386.deb
executed >sudo dpkg -i Delicode-NI-mate_1.20-ubuntu_i386.deb
It compained that I had 4 libqt4 dependencies missing.
From this link:

It told me to run:

sudo apt-get -f install
It did something, but I’m not sure if it then removed my Ni Mate program.

So maybe I’m okay, but how do I try to start Ni Mate to see if everything is all right?

Ni mate stalls at “Loading Configurations”

I think when I run :
sudo -apt-get -f install
it removes Delicode Ni-Mate, as I can’t find any reference to that when I search my files.
So for 2 of the 4 files I need:
libqt4-opengl and libqt4-network, they’re in my synaptic package manager and shouldn’t be a problem to install.
But if you look at this website:

It says that
libqt4-core and libqt4-gui
don’t exist anymore and were “dummy packages with dependencies to other packages”.
So I’m afraid I’m out of my depth. I’m not sure how to fix this without screwing up my entire operating system.
Thanks for any help.


Next, from the above website I did the following:
dpkg-deb -x yourfile.deb newdir
dpkg-deb --control yourfile.deb newdir/DEBIAN
gedit newdir/DEBIAN/control

and changed the libqt4-gui (>= 4.8.1) to libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4
dpkg -b newdir modified.deb
I also deleted the libqt4-core dependency.

Then I ran:
sudo dpkg -i modified.deb and got the following files missing:

This time when I ran:
sudo apt-get -f install
it didn’t remove Nimate.

But if I go to opt/NI_mate and run:
I get the error: no such file or directory
But is included in libasound2
and I have libasound2 already installed on my computer.
Any ideas?


I have the file at:
So why can’t Ni Mate find it?
(+ Is it okay that I deleted the libqt4-core dependency?)


If I run :
ldd /opt/NI_mate/Delicode_NI_mate
I get this output: => (0xf7f03000) => not found => not found => not found => not found => /usr/lib/i386-linux-gnu/ (0xf7de1000) => /usr/lib/i386-linux-gnu/ (0xf72c9000) => /usr/lib/i386-linux-gnu/ (0xf716f000) => /usr/lib/i386-linux-gnu/ (0xf6e69000) => /usr/lib/i386-linux-gnu/mesa/ (0xf6df8000) => /lib/i386-linux-gnu/ (0xf6dd9000) => /usr/lib/i386-linux-gnu/ (0xf6c53000) => /lib/i386-linux-gnu/ (0xf6b54000) => /lib/i386-linux-gnu/ (0xf6b37000) => /lib/i386-linux-gnu/ (0xf6961000) => /usr/lib/i386-linux-gnu/ (0xf694c000) => /usr/lib/i386-linux-gnu/ (0xf6801000) => /usr/lib/i386-linux-gnu/ (0xf6745000) => /lib/i386-linux-gnu/ (0xf6740000) => /usr/lib/i386-linux-gnu/ (0xf6734000) => /usr/lib/i386-linux-gnu/ (0xf66eb000) => /usr/lib/i386-linux-gnu/ (0xf66cf000) => /lib/i386-linux-gnu/ (0xf659f000) => /usr/lib/i386-linux-gnu/ (0xf6565000) => /lib/i386-linux-gnu/ (0xf6546000) => /usr/lib/i386-linux-gnu/ (0xf64e6000) => /usr/lib/i386-linux-gnu/ (0xf64dd000) => /usr/lib/i386-linux-gnu/ (0xf64c1000) => /usr/lib/i386-linux-gnu/ (0xf64ae000) => /lib/i386-linux-gnu/ (0xf64a4000)
/lib/ (0xf7f05000) => /lib/i386-linux-gnu/ (0xf6479000) => /usr/lib/i386-linux-gnu/ (0xf6475000) => /usr/lib/i386-linux-gnu/ (0xf646f000) => /usr/lib/i386-linux-gnu/ (0xf6467000) => /usr/lib/i386-linux-gnu/ (0xf6464000) => /usr/lib/i386-linux-gnu/ (0xf6446000) => /usr/lib/i386-linux-gnu/ (0xf6442000) => /usr/lib/i386-linux-gnu/ (0xf643b000) => /usr/lib/i386-linux-gnu/ (0xf6438000) => /usr/lib/i386-linux-gnu/ (0xf640c000) => /usr/lib/i386-linux-gnu/ (0xf63ef000) => /usr/lib/i386-linux-gnu/ (0xf63e9000) => /usr/lib/i386-linux-gnu/ (0xf63e2000) => /usr/lib/i386-linux-gnu/ (0xf63cc000) => /usr/lib/i386-linux-gnu/ (0xf6365000) => /usr/lib/i386-linux-gnu/ (0xf6361000) => /lib/i386-linux-gnu/ (0xf62ea000) => /usr/lib/i386-linux-gnu/ (0xf62e1000) => /lib/i386-linux-gnu/ (0xf62db000) => /lib/i386-linux-gnu/ (0xf62c0000) => /usr/lib/i386-linux-gnu/ (0xf62b9000)

Of the 4 files not found:
this one is in /usr/lib/x86_64-linux-gnu/
and the other 3 files (,, )
I found in /src/nimate/newdir/opt/NI_mate which was created when I altered the deb dependencies for Delicode-NI-mate_1.20-ubuntu_i386.deb, so the files must be part of your program.

I’m afraid I’m pretty lost.


I was trying to install the 32 bit version I think:
so the program wasn’t looking in the 64 bit directory.

I did the whole same process with:

Now Nimate opens. But it wants me go to a Ni-mate web page to register the sensor, but the web page couldn’t be found.

I think I noticed reading somewhere that the version 1.2 licenses need to be done manually. If so, what is my next step?

I think I’m getting closer!

Thanks for your help.


Good to see you got NI mate running. I’ve sent the license over PM.