"Illegal instruction (core dumped)" v1.20 Lubuntu

Hello!

I’ve just gotten a trial for v1.20. (thank you again, Julius)
it loads, and then a few windows show up, but then it crashes.

/usr/share/themes/Lubuntu-default/gtk-2.0/apps/thunar.rc:55: error: invalid string constant “thunar-statusbar”, expected valid string constant
Warning: USB events thread - failed to set priority. This might cause loss of data…
QFSFileEngine::map: Mapping a file beyond its size is not portable
QFSFileEngine::map: Mapping a file beyond its size is not portable
Illegal instruction (core dumped)

is all the terminal says. is the USB connection too unstable or something?
I’m running Lubuntu 15.04 on a fairly old laptop.

thanks!

Hello!

NI mate uses OpenNI which officially supports Ubuntu 12.04. Unfortunately, OpenNI 1 was last updated in 2012 and there is no more recent Linux release available. OpenNI 2 has had some development activity, but NI mate 1 (on Linux) doesn’t have a version available that supports OpenNI 2. The libfreenect project is quite active on Linux, but there are some missing external dependencies that don’t make it an option for NI mate. Most likely the problem here is related to something having been updated in Ubuntu that breaks OpenNI 1.

Which sensor are you attempting to use? Are you using the sensor in USB2 or USB3 port? Generally you should go for USB2 with any sensor on Linux and OS X.

Does your sensor work with any other Kinect projects, maybe some that use libfreenect? There’s an example on how to build the library and test it here: http://openkinect.org/wiki/Getting_Started#Ubuntu_Manual_Install

using Kinect model 1414 with 2.0 USB ports.
the freenect-freeview works fine.
your assumption is probably right, :confused:

any suggestions?
(use Windows, maybe? :P)

I’m afraid there’s not much to do, apart from getting an older version of Ubuntu. If you’re unwilling to downgrade, there’s the possibility of using a virtual machine. I’m not sure but it might be possible to run Ubuntu 12.04 using for example KVM, assuming the virtual machine gets prioritized access to the actual USB controller.

Linux version of NI mate 2 is not yet decided, but there’s some discussion about the possibility of one happening here: Ubuntu edition for NI MATE V2.xx. In this case we’d be faced with the same OpenNI problem though.

hmmm… I’ve installed Lubuntu 12.04, but it still dumps core.

QGtkStyle was unable to detect the current GTK+ theme.
Illegal instruction (core dumped)

am I supposed to download anything other than whats in the .deb?

I’m guessing its a graphics issue, but I’m not sure.
I have tried the Xorg and proprietary nvidia drivers (not sure if they’re outdated or not) the terminal output changes, but I’m not sure if its important.
(I’m not sure of a lot of things, if you can tell)
I can’t find any learning resources on openNI, so I honestly don’t know wth it is.
my understanding is that its some sort of helper for receiving and sending sensor data.

so any help regarding openNI or any potential graphic problems would be appreciated. thanks! :relaxed:

Could you run ldd on the NI mate binary? It should be at /opt/NI_mate/Delicode_NI_mate

Are you running NI mate from the bash script or the binary itself? The shell script (/opt/NI_mate/Delicode_NI_mate.sh) sets up the LD_LIBRARY_PATH so that the required libraries are found.

used the shell, still crashes, but now the binary gives me:

./Delicode_NI_mate: error while loading shared libraries: libOpenNI.so: cannot open shared object file: No such file or directory

this happens as soon as you run it, none of the loading slashes show up.
I see “libOpenNI.so” in the folder.

here is the output of ldd:

linux-gate.so.1 =>  (0x00abf000)
libOpenNI.so => not found
libcryptopp.so => not found
libzbar.so.0 => not found
libasound.so.2 => /usr/lib/i386-linux-gnu/libasound.so.2 (0x00d04000)
libQtOpenGL.so.4 => /usr/lib/i386-linux-gnu/libQtOpenGL.so.4 (0x00153000)
libQtGui.so.4 => /usr/lib/i386-linux-gnu/libQtGui.so.4 (0x00df6000)
libQtNetwork.so.4 => /usr/lib/i386-linux-gnu/libQtNetwork.so.4 (0x00775000)
libQtCore.so.4 => /usr/lib/i386-linux-gnu/libQtCore.so.4 (0x003d7000)
libGL.so.1 => /usr/lib/nvidia-304/libGL.so.1 (0x00250000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0x00110000)
libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0x00beb000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0x0032c000)
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0x00366000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0x008c2000)
libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0x0012b000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0x124ab000)
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0x006c0000)
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0x0013d000)
libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0x00ac0000)
libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0x00146000)
libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1 (0x00384000)
libaudio.so.2 => /usr/lib/i386-linux-gnu/libaudio.so.2 (0x003b8000)
libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0x14b5c000)
libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0x006c5000)
libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0x006ef000)
libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0x00a6b000)
libSM.so.6 => /usr/lib/i386-linux-gnu/libSM.so.6 (0x00358000)
libICE.so.6 => /usr/lib/i386-linux-gnu/libICE.so.6 (0x0072f000)
libXi.so.6 => /usr/lib/i386-linux-gnu/libXi.so.6 (0x00749000)
/lib/ld-linux.so.2 (0x0070d000)
libnvidia-tls.so.304.128 => /usr/lib/nvidia-304/tls/libnvidia-tls.so.304.128 (0x00361000)
libnvidia-glcore.so.304.128 => /usr/lib/nvidia-304/libnvidia-glcore.so.304.128 (0x0fa6c000)
libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0x00b5b000)
libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0x00b7c000)
libXt.so.6 => /usr/lib/i386-linux-gnu/libXt.so.6 (0x025f0000)
libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0x003d1000)
libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0x00ba6000)
libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0x006b4000)
libuuid.so.1 => /lib/i386-linux-gnu/libuuid.so.1 (0x00705000)
libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0x0075a000)

To be sure, you’re on a i386 version of Lubuntu, right?For amd64 you should get the 64-bit version of NI mate.

I don’t see anything noteworthy in the ldd output. As long as you run NI mate via the shell script the missing libraries are loaded from the install directory.

This could be a lot of issues. Which version of OpenGL do you have available? You can get this information by running glxinfo |grep -i 'OpenGL version string'

yes, I use i386 version of Lubuntu. (should I use 64bit?)

OpenGL version string: 2.1.2 NVIDIA 304.128

OpenGL version 2.1 sounds like the Mesa driver being used. I don’t think NI mate 1.2 requires OpenGL 3, but it’s been a while since we’ve worked with the old version. If you can get OpenGL 3.X running you might get somewhere.

I don’t think it makes a difference to try x86_64.