Is OSX Mojave supported?

+1 for updates. I also have a Kinect v1 (Xbox 360), had it working with High Sierra, and would like to get it up w/Mojave.

Hi, I am having the same issue for a current project and am keen for a solution. My two Kinect 360’s worked on High Sierra but since updating to Mojave, neither work.

When i connect the sensor, the status reports as “Error: Process Operation timed out”.



I’m having the exact same problem
Kinect 360 showing Error : process operation timed out.

the same sensor works with the same os : 10.14.1 with other apps such as Scanekt

It would be good to get an update of Nimate for Kinect xbox 360 model to function with the software on OSX Mojave.

I wonder if this forum is no longer supported on Mojave… :crazy_face:

I do wish they updated soon. I just found out this software and I really want to try it out.


Same problem. NI Mate is not connecting in Mojave to my Kinect1414.

In my System Information tool under USB Xbox Camera is listed…and I can get an image in Skanect.

Anybody have a solution to the Kinect 360/Mojave 10.14 issue yet? Thank you!

Hi Jesse,

Could we all have an update on this issue? Can we expect to use NI Mate on a Mac any time soon? It’s been 5 months…

Unfortunately we haven’t had the resources to look into the Mojave issues. For now, the best option is to use an earlier version of MacOS or, if possible, give the Windows version a try.

We got it working on Mojave by installing libusb on the machine (using macports or brew).
Initialization still hangs for ~15 seconds but at least it’s working.

Hey Sly,

Can you maybe explain us a little bit more on what you did and how you did it? I am also trying to get Kinect for Windows 2 (1414) working on Mojave, but I am struggling as I’m new to using libusb and Macports.

Thanks in advance!

1 Like

My Kinect V1 360 is working on my Macbook Pro 2013 with Mojave on it with a different app, but the app is not too good and I paid for it so not happy. it messes up my legs and messes up everything if I turn my back - It was only worth the money to prove that my Kinect 360 works and registers with Mojave.

Alas I got the program this morning as I just touched down on Earth today. If I new NI Mate worked for Mac I would have tried it first but the (old) things I saw on youtube suggested that it was only or PC (sigh)

Anyways - long story short - I’m still on Mojave and it looks like the app store has a further pdate so I’m not fully updated on it. I’m haveing the same problems that everyone else is having (NI Mate not registering the sensor - Error no midi ports available - no sensor found etc)

I listened to the NI Mate support and downloaded the ZIPPED ALPHA FILE.

I installed it and - as it says in the list of known issues - It crashed the first time I ran it - but then the second time - it worked.

And this is on Mojave 10.14 - it worked. I waved at my self a couple times and felt a little spec of relief while knowing that all the other known issues on the list warned me I practically wouldn’t be able to get up and dance without it crashing. Then it crashed.

I clicked back on startup and it said “error restarting” but it wouldn’t restart. I clicked “restart now” and “don’t use” but it wouldn’t work.

Since then I have restarted it and it still wont work. I’ve tried to change settings in preferences and it crashed when restarting.

3 times I’ve clicked on the unzipped alpha file and it’s said “The application “” is not open anymore.” - All I can say is that this is fixed by unzipping the alpha file again and clicking on it and the program runs faster that if I click on the 2.14 install.

I ignore all notices to update to 2.14 and start the program, and even reverted back to default settings and nothing - but - as it says in the NI MATE support - my sensor is working and ALWAYS shows the red light at all times. Again this is in Mojave 2014.

I’ve re-opened the crap app that I paid for a couple times just for faith and perseverance lol. There’s a way to make this work, but you guy’s are the rocket scientists and I’m the visiting Alien…

All I can say is that there is a link in the ALPHA file where you can “install support for:”

OpenNI for Kinect for XBox 360
(Kinect for windows2 and for Kinect for Xbox One with adapter
Leap Motion)

but when I click on the link it is dead - it says

OpenNI sensor:
Download error: Error downloading - server replied: Page Not Found
try again close

I click try again and same message - this is the first and only time I’ve actually seen "Kinect for Xbox 360 in the whole of NI MATE

If anyone makes sense of this and fixes the issue - You’re welcome.

Oh - and I don’t know if it helps, but the half dead program I paid for didn’t install correctly as well. I had to open utilites and type csrutil disable or something like that to disable the system integrity and then enable it after I installed it - so I tried it with NI MATE -

so if you install the alpha and it doesn’t work - try that if you know about it.

Jesse - My other issue is that it says that another known issue is that Kinect Xbox 360 ,ay not work properly on USB 3.0 and Kinect V2 wont work on USB 2.0 - but I don’t have USB 2.0 ports - i only have 2 USB 3.0 ports.

As much as I want to sit here and cry about that until my tears destroy my keyboard and USB 3.0 ports - if you have Mojave and USB 2.0 Ports you might be in luck.

And just so you know - As with all of Jesse’s advice - I ran out and bought 2 kinects. I went to buy 1 but it was so cheap I couldn’t resist - and thank God I looked underneath and both were 1414 - so if you don’t get a constant red sensor light after reading this (or if you DO and yours says 1473 or whatever it was) write it here before Jesse get’s back from his year Sunbathing in Ibiza…

As much as I’d like to blame NI MATE - it’s clear that Microsoft and Apple insist on using the same hardware and technology whilst making sure we struggle to get the best of both worlds - so I hope this will help someone if it can’t help all of you.

If I make a break through I will let you know but I’m about to restart my mac and also enable the csrutil again (or whatever it’s called) in the Terminal as restarting is the only thing I haven’t tried since I waved at myself…

Sorry - I don’t know if I mentioned it - but when the sensor did display a “live” image it was using OpenNI2 - right now it just keeps trying again after a certain period but the sensor light is still on - in version 2.14 my kinect 360 was flashing but I didn’t get the red sensor light on once. so you’re best bet for mojave could still be the alpha version.
Jesse - I’m new to this stuff - I still have 2.14 installed. do I need to uninstall it? I’m just not opening it and alpha still worked briefly but at one point I noticed that both versions were open in my system tray…

Also - I don’t know - as I have 2 3.0 USB ports - but mine might just work properly if I run out and trade the 2 kinect 360’s for a V2 - but I’m gonna stick with them for now as they work with the crap app I paid for and partly worked with this. so if there is still an issue with the USB ports - make sure you guys happle looked on apple and know the difference between a USB 2.0 and USB 3.0 before you ask for a soultion to a “known issue.”

So yeah Mojave 10.14 is the latest MAC version that has shown a breath of working - I don’t know what version sly is using. I want to try the libusb thing but I just got my MAC - I don’t know about all that stuff but I know what homebrew means and I ent ready to do anything other than access the terminal for at least 2 years - so if you are deep into Macs that way - I hope this nails it for the Mojave heads.

And Jesse - I have a laptop with windows 10 so I may just try to use it that way - but my MAC has better ram and processor - so I wrote this to help you figure something out more than ask for a solution

Is there any link to that “support for Kinect for Xbox 360?”

My - Bad - it’s a “13-inch” - mid 2012 macbook

I think it was El-Capitan 10.11.6 but I had to update it to 10.12 to get the apps I wanted on the app store so I just updated it to mojave. I just remembered seeing 13 out the corner of my eye when I looked at the version (10.14)

I can restore it back to 10.11.6 as I backed up my macbook the day I got it but I don’t want to just yet I’d rather help anyone on here in Mojave or earlier while I just found out I could kinect my connect to it.

Yeah that’s what I said… . connect my kinect

~Update - 03/08/19 - It seems to be working better than it did yesterday and I didn’t do a thing - so the answer to your question is - yes Mojave is supported - may not be very well but at the moment I’ve had it open for half an hour without crashing - if it keeps it up for a week I’ll most likely purchase the full version but use v2.13 if that’s possible until NI mate figure out what it is in 2.13 that’s making it work on Mojave.

Again - I have v.2.14 installed but I’m not using it - I just downloaded the alpha which displays v2.13 while NI mate is open and the kinect 360 (1414) is working automatically under OpenNI 2.

if this doesnt work for you on Mojave with kinect 1414 I can only suggest you type csrutil in google and follow the exact instructions to diable it then re-install 2.14 and then the alpha 2.13 and then enable cs rutil again

I’ll let you know how stable it’s going for me next week. Good Luck

Hi - I’d like to try installing v2.13 on my Mac to get the Kinect to work but I can only find the link to download the latest version - can anyone post the lionk to download v2.13?


1 Like

Here you go: What happened to V1.XX? I use that software!

1 Like

Dear @Jesse,
can you tell us if you plan to update nimate to make it work with mojave?
cos you’re download page mentions mac os 10.9 +
and it means a lot for us.
Thanks for your reply

Unfortunately we don’t have any plans for a new update, and while we know Mojave users experience problems getting NI mate running, currently NI mate is sold as it is.

I have 2 OSX on the same macbook, and while NI and Kinnect works very fine and as expected on High Sierra, it doesn’t work on Mojave, the workaround is to downgrade your mac or install a High Sierra on a different Partion