Kinect model 1517 Windows 10 problems getting it to work


#1

Alright so I have been at this for about 5 hours now and no luck.
First thing my specs
Windows 10 64 bit
GTX 1080ti
32 gigs ram
Intel core I7 7820x
I have both usb 2 and 3 ports on the front of my case
kinect for windows model 1517

First thing I tried was to install the official SDK 1.8 and toolkit 1.8. in device manager I had kinect for windows with 3 devices under it security audio and camera I had output to the toolkit when I ran a test application from the SDK. However when I went to NI Mate there was no such output but the software detected openNI2 and tried to use it. When I pressed the start sensor button it would load for a bit then return me to sensor stopped start sensor again. So I uninstalled everything. Disabled driver signatures then reinstalled NI Mate with primesense 1 thing selected in the installer. I checked device manager and I find that it has two devices under primesense being kinect audio and kinect camera no motor was in the list like the FAQ said there should be. however the kinect has a flashing green LED and the power LED on the cable is on and it is plugged into my USB2 controller now when I enter NI Mate setup and scan for sensors nothing shows up at all.


I hope that print screen works but that is where I am now. any help would be greatly appreciated.

edit
because print screen seems to work here goes


device manager currently

edit 2
It also seems that I can no longer get output to the toolkit


#2

Check whether you device adapter is working or not. Your device is not getting power source to kinect


#3

just checked unplugged every part of the adapter the LED is on on the cable and the kinect LED is blinking green


#4

Hello!

For the 1517, you will need to place this additional DLL in the NI mate OpenNI2 sensor directory: https://ni-mate.com/release/additional/Kinect.dll

The directory (by default) is: C:/Program Files/Delicode/Delicode NI mate 2/Delicode_Sensor_OpenNI2/OpenNI2/Drivers


#5

okay now I have a different problem. it is showing up on the list after I added a dummy open NI2 and the sensor starts then sends me an error sensor will restart in 10 seconds


here is the log


#6

So I fixed the issue to do this I installed the official 1.8 sdk and toolkit along with placing the dll file in the open NI2 folder so that’s neat.