Kinect v2 issues on Windows 10

  • Is Z Vector set to use Kinect for Windows sensors? You can change this from the preferences.
  • Did you install the required driver when you installed Z Vector? It needs to be checked on the installation components page
  • Does the log window display any errors?
  • Which pipelines are enabled in the preferences?

Z Vector V1.12 released!
Z Vector V1.12 released!

Yes my Kinect is for Windows sensors. I can using for other software.
When I open Z-Vector shows “system error”:

I had reinstalling Z-Vector. But the problem is still.


Which graphics card does your sytem have? This is the OpenCL dynamic library which is installed with your graphics card drivers. This problem might be solved by simply updating your GPU drivers.


My graphics card is nvidia GTX980M. I had installed new graphics driver and reinstall ZVector. That “OpenCL” problem is gone now.
But ZVector still can’t connect with sensor? Please check the photo that “No depth data” and log information?



Could you check the “sensor debug” box in the preferences and take another screenshot with the log window open?

“-99” is a libusb / UsbDk error that happens while the library is enumerating connected USB devices. Did the UsbDk driver install successfully when you installed Z Vector? You can verify this by checking the if “UsbDk runtime libraries” is listed in “Programs and Features”.

Is the Kinect connected to a USB3 port? If you have any other USB devices connected that take large amounts of bandwidth you should unplug those.


Yes I had checked the “sensor debug” box. Please check attached photo.

Dose “UsbDk runtime libraries” is “Vulkan Run Time Libraries”? Please check attached photo which list of “Programs and Features”.

Yes my Kinect is connected to USB3 port. I don’t have others USB devices connected.


No, “UsbDk runtime libraries” should be listed just as that, UsbDk Runtime libraries. You will need to have them installed to use Kinect 2 with Z Vector.


Where can I download and install for “UsbDk Runtime libraries”?


Run the Z Vector installer and check the UsbDk driver during the installation.


Hello there I am having exactly the same problem and I have tried everything. I would greatly appreciate some help!

Note That all graphic card requirements and others are inline with what the software and Kinect for windows need however windows keeps blocking the USB dk files that do not install correctly, even though I can find them in the program list. Also note that I have followed the instruction to allow installing unsigned files


I wonder if there’s something that needs to be updated for our UsbDk installer package. Could you try installing this version of UsbDK?

What is the exact error Windows gives you when you try to run the installer?

Is this on Windows 10?


Thank you for your reply.

I’m working on an Asus computer that has window 10 on it.

The message that is being prompted when I install your software is: a digitally signed driver is required (red hat) thus windows is blocking its installation and as a result all USB were shut down and none were working

I have tried installing the new USB dk driver u sent which was better since all usbs were still working but the software prompted me with an error message: the program can’t open because opencll.dll is missing from Your computer. Try re-installing. I did but the same error occurred.

Many thanks for your time and help on figuring out the installation problem and solution


The OpenCL error means the graphics card driver on your system doesn’t support OpenCL. You can probably fix this by simply installing the latest available GPU drivers.


Hi, I download the trial version of Z-vector and I’m running it on Kinect V2. it giving me this message in both input window “no data from NI mate, only background depth available”. So technically I can not try the effect. Is there is something wrong with my installation or it’s because I’m running on trial version? please see the attach of the screen shot. thanks.


“No data from NI mate” means the “Delicode NI mate interop” is enabled in the settings. This is a feature that allows using NI mate with Z Vector, feeding the live streams to Z Vector from NI mate. This is useful if you don’t want Z Vector to capture the real devices and need NI mate to do some processing on the streams. Disable this feature in the preferences and restart Z Vector.


Thank you very much it works:smiley:


Hello , i have exactly the same problem .The usbdk file knocks out all my usb controllers on reboot .I have an ASUS X99 Deluxe motherboard.I have tried turning signatures off too…Even unchecking part of the NI MATE uninstall… i have added an external powered USB3 HUB to protect the Kinect from NI MATE usbdk but nothing has worked !..I can only get my pc back with a full system restore with an old mouse as my usb keyboard and usb mouse no longer work till restored.
You can run all the software in windows sdk ni mate fine …but when you reboot the pc that’s when it knocks ALL the usb drivers out AGAIN …I dont think NI MATE plays well with ASUS and asmedia usb …Which is a shame as a lot of new motherboards are ASUS …Youmna if you found a fix or anyone here at ni mate know what to do please let me know

Kind regards Gary


@Gary: Does the new version of UsbDK work properly? You can get it from this link.


2 posts were split to a new topic: NI mate + Kinect v2 issues on Windows 10