Ni mate 2.13 not launching in El Capitan


#1

Ni mate 2.13 is not launching. Nothing happens when I click to launch the application. Anybody have a solution for this?

System: MacbookPro, OSX 10.11.6


#2

Hello!

Does the system crash handler appear?

What’s the output if you launch NI mate from the terminal? This is done by running this command: /Applications/Delicode_NI_mate.app/Contents/MacOS/Delicode_NI_mate


Ni-Mate don't start
NI mate v2.14 released!
#3

System crash handler does not appear. Just nothing happens.
Launching from terminal outputs:
Illegal instruction: 4


#4

This is a problem that typically happens if the program being launched has either been built for too new MacOS version (we target 10.9) or the processor on your system does not support some hardware acceleration / optimization feature. A few people have reported this problem, which is strange since El Capitan is definitely more recent than 10.9.

Which MacBook Pro is this?


#5

My macbook pro is:
MacBook Pro (15-inch, Mid 2009)
Processor 2,8 GHZ Intel Core 2 Duo
Memory 8 GB 1067 MHz DDR3
Graphic NVIDIA GeForce 9400M 256 MB


#6

I’m having the same problem

My macbook is:
MacBook Pro (15-inch, 2.53GHz, Mid 2009)
2.53 GHz Intel Core 2 Duo
4 GB 1067 MHz DDR3
NVIDIA GeForce 9400M 256 MB


#7

The problem could be related to the MacBooks being a bit on the older side. On a quick glance, both MacBooks should support the specific acceleration techniques that are used by NI mate, but it’s a bit difficult to know what it precisely is what’s causing this, as long you’re on MacOS 10.9 or later. Do you have any other computers on which you could try running NI mate?


#8

I’ve no access to another Mac at the moment but due to start-up kernel panics I’m currently experiencing I’ll be reinstalling my system & verifying my memory cards over the coming weeks. Hopefully a properly functioning system might resolve the issue. Keep you posted


#9

I don’t have access to another mac at the moment but it’s possible I could have a mac book air to try it on in coming weeks … but that’s no guarantee.


#10

Hi, I get this error too when i run v2.14 from terminal. Great. And I have to give a workshop on Kinect motion-tracking in 24 hours…

Using Kinect Xbox 1414

V2.14: “Illegal instruction: 4”. I don’t even get a launch screen.
V2.12 launches at splash screen and requests to send crash log.
V2.11 launches but then crashes.
V2.10 launches fine, detects my Kinect, but won’t “start” it. Log says:

20:01:41: Starting input 1: Kinect for Xbox
20:01:41: Input 1: Live sensor not found.
20:01:42: Input 1: startlive failed
20:01:42: Input 1: shutting down sensor
20:01:42: Input 1 quit normally.
20:02:02: Starting input 1: Kinect for Xbox
20:02:03: Input 1: Live sensor not found.
20:02:03: Input 1: startlive failed
20:02:03: Input 1: shutting down sensor
20:02:03: Input 1 quit normally.

My macbook is:

MacBook Pro (15-inch, Mid 2009)
El Capitan
2.66 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3
NVIDIA GeForce 9400M 256 MB


#11

It’s good you tried the older versions. The fact that the older versions don’t have this problem (even if there are others) suggests this is indeed something that was introduced in 2.13 / 2.14. We’ll have to do some more research into this to know what the problem is.


#12

Hi, any solution for El Capitan users?
It would be nice to get NI t work…