NiMate doesn't start up

I installed nimate 2.14 on windows 10 pro. Before installing I disabled driver signature enforcement. I have a xtion prolive sensor which i haven’t plugged in yet. When I click on the “Delicode NI mate 2” icon nothing happens. Am I missing something?

Making progress. Apparently I need to open the program in the windows system tray then press “control interface”. Next, how do I get nimate to recognize my asus xtion prolive sensor? Do I need to install asus’s software to create openni files somehow? Isn’t there a tutorial of sorts to walk me through this?

Maybe I’m getting closer still. I think possibly nimate is noticing my sensor, because if I try in “setup” to set up a openni sensor, rather than a openni2 sensor it says “can’t find sensor” when i click on it to the left. But with the openni2 sensor it doesn’t say that.

So next problem, if i go to the openni2 selection and hit source “example” ( or also “live” for that matter), and then hit “start sensor”, to the left it says “running” but then immediately turns to “stop”. Maybe if it didn’t automatically turn off my system might actually be working? What should I do?

This is the log output:


14:30:36: Input 1: Startup succesful

14:30:38: Input 1: Subroutine update timeouted after 3000 milliseconds.

14:30:38: Input 1: Usually this is a problem related to the USB device being operated. Make sure the USB device is properly connected and you aren’t running out of USB bandwidth.

14:30:39: Input 1 quit normally.


But that doesn’t make any sense, since the example clip isn’t coming from the USB port.

Hello!

Good to hear you made some progress.

Asus Xtion Pro Live (is it Pro Live?) sensors use the OpenNI2 driver, so you must use that sensor type in NI mate. In addition, the “unsigned driver” issue only applies to OpenNI1 and XBox 360 Kinects. With Xtions you don’t need to care about that.

The “example” button loads an example recording, not real data. If you added a device by clicking “OpenNI2” on the setup page, you added a dummy device which is designed for only working with recordings, not real hardware. To add the real device, you must click “scan” on the setup page and wait for your sensor appear in the setup page sensor listing, after which you can press “use” to start the sensor. If the setup page does not list your sensor, NI mate does not detect it.

Are you using the XTion in a USB2 or USB3 port, and do you have the updated firmware (required for USB3)?

Thank you for your response. It seems that at times I can keep it from stopping. I’m not sure how, it appears a bit random. There are still problems though.
First, to answer your questions. I’m using ASUS XtionProLive, the OpenNi2 driver comes up automatically when I start up. It’s not a “dummy” as I know what that looks like when I try to create a driver when it’s not plugged in. It appears to be a USB 3.0 port on Windows 10. When I go to Windows Admin Tools, then USB it says “Intel USB 3.0 eXtensible…”
I got the example to stay on now. For some reason before I couldn’t. But there is no skeleton moving like when I run the example in a dummy sensor. I don’t know why. Sometimes I can get the live sensor to stay on for awhile by moving my hand in front, but it’s pretty hit and miss. The information I’m seeing on the screen is pretty unintelligible though. I’m thinking it might have something to do with the frame rate. I went to Preferences - OpenNi2 and checked “Default to USB3 mode”, but that didn’t help.
Is there USB 3.0 firmware that I need to install?
Thanks for your help.

Asus did release a firmware patch, but it’s no longer available on any official sources. We have a copy here: https://ni-mate.com/release/firmware/FW579-RD1081-112v2.zip

Be aware that installing the firmware is done without any warranty from us, and should only be done if you can’t get the sensor running otherwise.