No feed with Kinect v2


#1

Hi,
I’m not sure if this is the right place to put this as I was unable to figure out how to start a new thread.
I have a kinect v2 and have been stummped by NI MATE whilst trying to set up a home motion tracking thing.
I am able to get a feed from my kinect in kinect studio but when i open up NI MATE I am unable to see anything and after a while it just straight up crashes, I have tried restarting everything and all the other basic things to try and get stuff to work but to no avail.
the log says:

15:14:57: Qt WebEngine ICU data not found at D:/Qt57/5.7/msvc2013_64/resources. Trying parent directory…
15:14:57: Qt WebEngine ICU data not found at D:/Qt57/5.7/msvc2013_64. Trying application directory…
15:14:57: Installed Qt WebEngine locales directory not found at location D:/Qt57/5.7/msvc2013_64/translations\qtwebengine_locales. Trying application directory…
15:14:57: Qt WebEngine resources not found at D:/Qt57/5.7/msvc2013_64/resources. Trying parent directory…
15:14:57: Qt WebEngine resources not found at D:/Qt57/5.7/msvc2013_64. Trying application directory…
15:14:57: device status is 1
15:14:57: family 2
15:14:57: Spout server 1.1 initialized in DX11 mode.
15:14:58: QOpenGLWidget: Already initialized, setting the format has no effect
15:14:58: Spout server 1.2 initialized in DX11 mode.
15:14:58: Starting input 1: Kinect for Windows 2
15:14:58: Input 1: Creating QApplication
15:14:58: Input 1: Using shared memory for data
15:14:58: Input 1: Feed transmission is enabled
15:14:58: Input 1: K4W sensor
15:14:58: Input 1: initting websockets
15:14:58: Input 1: connecting straight to: localhost:22223
15:14:58: Input 1: websocket connectingstate
15:14:58: Input 1: No websocket available yet, so sending message at a later time
15:14:58: Input 1: waiting for response
15:14:59: Input 1: websocket connectedstate
15:14:59: Input 1: Using GPU (Spout) for shared textures with OpenGL version: 3.2.
15:14:59: Input 1: Created Z memory for sensor 1 6f2485a0-fd24-11e1-a21f-0800200c9a66
15:14:59: Input 1: Set Z memory uuid for sensor 1 4ad28739-bfe4-46df-8647-bdec95d660ea
15:14:59: Input 1: Startup succesful

but I have no idea what it means.

on the kinect for windows page it says: Running at 30/30 FPS Live then a couple other buttons, one saying stop sensor. I have tried clicking it and it says “stopped” straight away then if i click start sensor i get Running at -/- FPS Live.


Introduce yourself!
#2

I moved this in a new topic and deleted the other thread.

Could you see if the feed appears if you disable GPU Texture Transfer in the NI mate preferences? The usual Spout errors aren’t in the log, but it doesn’t mean there cannot be a GPU problem.


#3

Hi,

there is still no feed after I unchecked “Use GPU transfer” and restarted the program.
I also noticed under System information that its showing “Graphics card: Information is not available before sensor is started” im not sure if thats relivent but I thought i would add it


#4

Could you try enabling the libfreenect2 as the used driver in the preferences? If you haven’t installed it with the NI mate installer package, you’ll need UsbDK from here: https://github.com/daynix/UsbDk/releases/download/v1.00-19/UsbDk_1.0.19_x64.msi


#5

tried that, still nothing coming through :confused:


#6

Strange that Kinect Studio works - it uses the same MS SDK which NI mate defaults to on Windows. Just to be sure, are you certain Kinect Studio isn’t running in the background and keeping access to the sensor reserved?


#7

I have been closing Kinect studio once I have clicked the connect button


#8

I went into task manager and have these 3 running in the background: 1) KinectMonitor.exe 2) KinectService.exe 3) KStudioHostService.exe
the second one is using 4.3mb or ram the rest are at 0


#9

I’m pretty sure all of those are okay to keep running.

What happens if you unplug & plug the Kinect back in, then start NI mate? Maybe the USB connection is in some zombie state after KinectStudio used the sensor. Also try a different USB port.


#10


#11

I thought i would add a screen shot just incase im doing things wrong. this is what i get after i restart the program then plug in the kinect


#12

I tried it again and this time i am getting an Enumeration error


#13

I now dont even get the option to see the page which has the black screen. i feel like this has gotten worse :confused:


#14

I got the kinect for windows tab back but i had to put all settings back to defult


#15

also to add, My kinect is lighting up as it does when i am connected to kinect studio


#16

well now its working for some reason :confused: xD