Nothing Happens


#1

I just installed NIMate 2.14 on a Mac Mini (late 2010) running OSX 10.12.6 Sierra. It won’t start. clicking the rabbit ear logo does nothing. Any ideas why?


#2

Could you try starting NI mate from the terminal and include the output?

  • Open the terminal
  • cd /Applications/Delicode_NI_mate.app/Contents/MacOS
  • ./Delicode_NI_mate

#3

Illegal instruction: 4


#4

We’ve seen this earlier on some macs: NI mate v2.13 released!

Unfortunately, we haven’t been able to yet find out what it was that caused this. We suspected it was a problem with older Mac processors not supporting some acceleration technology NI mate uses, but that should have been solved in NI mate 2.14 when we built the program to be backwards compatible.

Do you have any other Macs available on which you could try NI mate 2.14?


#5

Yeah, I use it regularly on a late 2013 MBP running OSX 10.11.6 with very few problems. I’m installing onto a couple of old Mac Minis for an installation.


#6

I just realised these old Mac Minis are only USB2, so the Kinect 2 won’t work anyway. time for a rethink…


#7

If you’re looking for a number of computers for an installation,we’ve had good experience with Intel NUCs and Gigabyte BRIX computers, although with Windows. On some NUCs we had to disable GPU texture transfer though.


#8

That’s a good idea Jesse - I might have to go PC for this project.
Does anybody want to buy a couple of old Mac Minis?


#9

Has this been solved? Running sierra on late 2011 macbook pro and finding that it does not open either. It loads the initial intro/credits window and then nothing (icon of app stays on).


#10

@mmo This is probably not the same problem as above. NI mate opens, by default, minimized into the MacOS menu bar. Click the rabbit icon and select “Control interface” to open the user interface.


#11

That option is not available, NI mate does not work at all.


#12

The tray icon does appear though? This suggests something is launched, as opposed to NI mate not starting at all.

Could you try executing NI mate from the terminal and see if you get the illegal instruction error?

  • Open the terminal
  • /Applications/Delicode_NI_mate.app/Contents/MacOS/Delicode_NI_mate
  • Include the output in your response

#13

I have a feeling that the Kinect 2 does not work with MacBook Pro late 2011, as you need USB 3 which it doesn’t have. Is that correct?


#14

Yes Kinect 2 requires USB3 as its bandwidth requirements are way beyond USB2 capabilities.