Problems with getting Kinect to work with NI mate V2

Continuing the discussion from Introduce yourself!:

Hi Cory. Welcome to the forum! Currently you have to get to trust level 1 before you can post a new topic. In order to get to trust level 1 you need to currently enter to five topics and read them through. I understand this can be a bit hard to do as the forum’s quite empty right now and there might not be a lot of interesting stuff posted yet. We’ll try to change that. All this because of spambots naturally. :smile:

In any case could you describe your issue in a bit more detail? Which OS are you running and are you connecting the Kinect to a USB2 or a USB3 port? There’s one known issue and that is the Kinect for XBOX model 1473, which unfortunately we cannot guarantee will work on Mac OS X.

Have you checked out our FAQ post on the topic?

Thanks so much for getting back to me so quickly. I did read the FAQ. I have model 1414 so I don’t think that’s the issue.

My computer:

iMac (27-inch, Late 2013)
3.5 GHz Intel Core i7
NVIDIA GeForce GTX 780M 4096 MB
OSX 10.10.3 Yosemite
It is USB3.

The Green light is blinking on the Kinect. When I plug it in and run NIMate it doesn’t recognize anything at all. I did, once, get it to recognize it briefly and it threw this error in the log: “Input 1: Error with enumerating connected devices: Can’t create any node of the requested type!.”

I then removed all other USB devices (except my keyboard and the dongle for my wireless mouse in the keyboard USB slot). But I haven’t been able to recreate that error or indeed get any signal whatsoever.

EDIT: I just noticed the FAQ asks if its connected to USB2. Does it need to be 2 to work properly?

Thanks for your help!

  • I have it plugged in USB 2
  • number on the back is 1414
  • Windows 8.1

In Log I’m getting: “Input1: CreateInterop error 3”

EDIT: do not have spec of the laptop. If you don’t know the solution on hand because the error message, I’l find out more and get back. (the laptop is at different place)

The Kinect 1 sensors generally need to be connected to USB 2 ports, but on Macs this is not always an option. What’s the output if you open your terminal and run a test with the sensor executable:

cd /Applications/Delicode_NI_mate/Contents/MacOS
./Delicode_Sensor_OpenNI sensor_test

Have you tried moving the Kinect to a different USB 3 port? Sometimes this helps as the USB ports may be connected to different USB controllers.

The CreateInterop is part of Spout’s texture share initialization. This means that for some reason your GPU drivers don’t support the required features for GPU texture transfer. You can disable this from the preferences.

Which GPU do you have? Have you updated the drivers for it recently?

I did move it to another port, though I could try that again.

I’m not sure how to run the test. I pasted the stuff you posted above into terminal and it said

Corys-iMac:~ Cory$ cd /Applications/Delicode_NI_mate/Contents/MacOS
-bash: cd: /Applications/Delicode_NI_mate/Contents/MacOS: No such file or directory
Corys-iMac:~ Cory$ ./Delicode_Sensor_OpenNI sensor_test
-bash: ./Delicode_Sensor_OpenNI: No such file or directory
Corys-iMac:~ Cory$

Hi Cory. Try this:

cd …/Applications/
./Delicode_Sensor_OpenNI sensor_test

Same thing:

Last login: Wed Aug 5 15:49:51 on ttys000
Corys-iMac:~ Cory$ cd …/Applications/
-bash: cd: …/Applications/ No such file or directory
Corys-iMac:~ Cory$ ./Delicode_Sensor_OpenNI sensor_test
-bash: ./Delicode_Sensor_OpenNI: No such file or directory
Corys-iMac:~ Cory$

What did you mean when you said “with the sensor executable?” Maybe I’m doing that wrong?

We’re merely missing your install folder. Have you copied NI mate to your Applications folder or are you running it from some other place on your hard drive?

We’d basically want to get an output (basically a log) from the sensor executable. That is the actual executable that creates the feed that is passed on to the NI mate parent software.

Ah, ok. It is in the applications folder but I can move it if needed.

Basically you need to open terminal, find the the exact folder where resides in (sounds like that’s going to be your personal Applications folder), go inside it and then do

cd Contents/
cd MacOS
./Delicode_Sensor_OpenNI sensor_test

and then just copy-paste the output here

Gotcha. :slight_smile: Here’s what it says:

Corys-iMac:~ Cory$ cd /Applications/ Cory$ cd Contents/
Corys-iMac:Contents Cory$ cd MacOS
Corys-iMac:MacOS Cory$ ./Delicode_Sensor_OpenNI sensor_test

Sensor test started for 200 frames:

progress: initializing device context
progress: USB enumeration
progress: USB open
Error with USB open: Failed to open the USB device!.
progress: enumerating connected devices
Error with enumerating connected devices: Can’t create any node of the requested type!.
startlive failed
shutting down sensor
Corys-iMac:MacOS Cory$

I noticed your new thread on running these test. My test results are above and I generated the .txt log file, as well. I can send that to you if you’d like and can tell me where to send it.

Thanks again for your help!

I am having similar problems.

Spoke to Julius - he suggested I ask here.

I can’t install my sensor basically. I get an error.

Also having issues with Kinect Launching.

  • Windows 8 64 bit
  • Kinect for Windows v1 model 1517
  • Kinect SDK v1.18

When Delicode_Sensor_OpenNI2.exe runs, I get the following error.

This application failed to start because it could not find or load the Qt platform plugins “windows”

I will also note that I don’t see any unsigned drivers in Device Manager.

This is a bit difficult to debug, but you could try to enable the logging for OpenNI. Right click NI mate in your applications, show package contents, go in Contents/Frameworks

Open GlobalDefaults.ini in a text editor and change the lines:




Do the same changes for the file GlobalDefaultsKinect.ini

Try doing the sensor test again and see if you get more verbose error messages in the terminal, or if a log file is created in the folder /Applications/ There may also be a log folder in there.

This error message is saying that for some reason the installer could not be extracted in your NI mate directory.

When you opened NI mate, did you do so by right clicking the icon in Applications and choosing “open”? If you double click the icon OS X should give you a warning that the application is not signed and prevent you from executing it, but it’s always a possibility NI mate was launched using some permissions that don’t allow changing the files inside the bundle.

Could you check if you have a file called in your temp folder? You can find this folder by opening your terminal and typing: echo $TMPDIR.

If the file exists, try manually unzipping its contents:

cp $TMPDIR/ /Applications/
cd /Applications/

Then try starting NI mate again and see if the sensor works.

If you get a permission denied error, try:
sudo chmod +x /Applications/*

We are still trying to iron out an installer that would work for all Mac users. Unfortunately, it seems different Macs handle permissions differently.

We detected a few issues in how the OpenNI2 sensor was packaged in 2.00. We’re going to release version 2.01 today with a fix.

EDIT: Release pushed to Monday as we faced some new issues that have to be patched first.

Unfortunately changing the log level to 0 didn’t seem to create a more verbose error or log; it looks the same as before…

One thing you could try is change the libusb library NI mate is using. We have two versions in the Frameworks folder and you can choose between them.

  • Open your terminal
  • cd /Applications/Delicode_NI_mate/Contents/Frameworks
  • sh fast
  • cd …/MacOS
  • ./Delicode_Sensor_OpenNI sensor_test

Do you have any other Macs that you could try with the Kinect, or other Kinects?