Sensor error, NI mate v2.14, macpro (OS Sierra)


#1

Hi,

I’ve installed NI mate v2.14 on my mac pro (OS Sierra). I’m using a kinect 360 (model 1414) and I’ve installed macports + usb libraries, OpenNI, Sensorkinect and NiTE. When I launch Ni mate I get ‘sensor error’. I’ve seen posts that say that the kinect 360 doesn’t work with USB3 (which is the only USB port I have) but I do get a feed from the sensor using an old Kinect Viewer app. Also, NI mate crashes after about 5 mins. even though I get no feed. Any ideas what the error could be? Or any suggestions for which sensor to get that will work with my setup?

Thanks in advance!


#2

Hello!

NI mate bundles all the libraries, so you don’t need to install libusb / SensorKinect / etc. I don’t think any libraries you installed cause issues as NI mate tries to first look inside the application bundle before trying system libraries. USB3 can work, but there may be issues with it.

Could you include the log window’s contents? Also, please send a crash report using the crash reporter when it opens.


#3

Hi Jesse,

Thanks for getting back to me! It looks a lot like it’s the USB that’s the problem. Any ideas of what I can do to fix it? This is from the log window:

17:57:56: Starting input 1: Kinect for Xbox
17:57:56: Input 1: Creating QApplication
17:57:57: Input 1: Using shared memory for data
17:57:57: Input 1: Feed transmission is enabled
17:57:57: Input 1: OpenNI sensor
17:57:57: Input 1: initting websockets
17:57:57: Input 1: connecting straight to: localhost:22223
17:57:57: Input 1: websocket connectingstate
17:57:57: Input 1: No websocket available yet, so sending message at a later time
17:57:57: Input 1: waiting for response
17:57:57: Input 1: websocket connectedstate
17:57:57: Input 1: Error with USB open: Failed to open the USB device!.
17:57:57: Input 1: Starting live sensor: PrimeSense SensorKinect
17:57:57: Input 1: Error with creating sensor device: Failed to open the USB device!.
17:57:57: Input 1: startlive failed
17:57:57: Input 1: shutting down sensor
17:57:57: Input 1: websocket closingstate
17:57:57: Input 1: websocket unconnectedstate
17:57:57: Input 1: client closed
17:57:57: Input 1 quit normally.


#4

The crash reporter doesn’t come up when I reopen. Do you have an email I can send it to?


#5

If the crash reporter doesn’t open, you can manually open it:

  • Right click Applications/Delicode_NI_mate.app
  • Show package contents
  • Contents/MacOS/Delicode_Crash_Reporter
  • Browse to the last crash, fill in the details and send the crash report
17:57:57: Input 1: Error with USB open: Failed to open the USB device!.
17:57:57: Input 1: Starting live sensor: PrimeSense SensorKinect 
17:57:57: Input 1: Error with creating sensor device: Failed to open the USB device!.

This looks like it might be a problem with the old version of libusb we are using with OpenNI1. Something you could try is switch the libusb bundled in the Frameworks folder to another one:

  • Go to /Applications/Delicode_NI_mate.app/Contents/Frameworks
  • Rename libusb-1.0.0.dylib to libusb-1.0.0.dylib.backup
  • Copy stable_libusb-1.0.0.dylib into libusb-1.0.0.dylib
  • Try the sensor again
  • If this fails, try copying fast_libusb-1.0.0.dylib into libusb-1.0.0.dylib

#6

Hi Jesse, thanks for that. I tried all the framework fixes, but still no luck. I also sent you the crash report. Any advice?


#7

I’m not seeing the crash reports at our side. Did the reports get sent successfully? You should get an email from our support system once the report has been transmitted properly.

You can also zip the .dmp files in /Users/youruser/NI mate/. Upload them somewhere or send them to me directly at jesse.kaukonen@delicode.fi.


#8

I got a confirmation email from support (request#1246) on the 26th of May. I’ve just sent off another report now. (#1266)


#9

Good Day,

it seems like i have a very similar problem. So i just append to this thread.
I have a MacBook Pro Retina 15’’- late 2103
MacOS Sierra - 10.12.5

NI Mate v.2.14 && NI Mate 2.13 osx_alpha

Kinect V2 for Windows (aka Kinect ONE, K4WV2…)
Asus Xtion Pro Live

I first installed v2.14 and was not able to run any camera at all.
It recognises the Kinect V2 but as status it keeps "Error, restarting in …"
The log says:
12:10:43: Starting input 1: Kinect for Windows 2
12:10:43: Input 1: Creating QApplication
12:10:43: Input 1: Using shared memory for data
12:10:43: Input 1: Feed transmission is enabled
12:10:43: Input 1: OpenNI2 sensor
12:10:43: Input 1: initting websockets
12:10:43: Input 1: connecting straight to: localhost:22223
12:10:43: Input 1: websocket connectingstate
12:10:43: Input 1: No websocket available yet, so sending message at a later time
12:10:43: Input 1: waiting for response
12:10:44: Input 1: websocket connectedstate
12:10:44: Input 1: config file is at /Applications/Delicode_NI_mate.app/Contents/Frameworks/OpenNI.ini
12:10:44: Input 1: Dump dir exists at "/Users/Fraggle/Library/Application Support/Delicode/Delicode Crash Reporter"
12:10:44: Input 1 crashed (view crash report)
12:10:44: Input 1 quit normally.

But there is no Crashlog.
It recognises the Xtion (OpenNI 2) but will stay “pending (Unknown error)” forever.

Also, the application will crash after a certain period - when Kinect V2 is connected to the Mac.

2.13 - osx_alpha recognizes and runs the Xtion without Problems (OpenNI 2) but fails when it comes to the Kinect V2.
(Won’t recognise and “Install support for:…” fails, because no valid download link)


#10

Hey.
Can’t get this thing working either.
I’m on iMac, 27", OS: Sierra, Kinect V2.
Can’t get the dude recognize by the NIMate and have NO CRASHES but this logs:

And I just bought a basic license (user: benjanowitz@gmail.com)
I need it for a very simple task: record some easy data movements into C4D and it’s VERY URGENT!
Please Help.
Ben.


#11

Sorry about the late responses!

@Fraggle

The sensor program crashes don’t start the crash reporter automatically (only NI mate itself crashing does that), but you can still open the crash reporter manually in the NI mate directory. Then browse to the crash that’s from that date and send that crash report. The crash reporter can be found by right clicking /Applications/Delicode_NI_mate.app -> Show package contents -> Contents -> MacOS -> Delicode_Crash_Reporter

The XTion Pro Live absolutely should work. It’s one of the sensors that we’ve found to be the most stable across all operating systems. If you have only the XTion connected, does enabling “Default to USB 3 mode” help? It’s in the preferences under “OpenNI2 Settings”

The OS X alpha release never had download links to it as it was only intended for debugging the Kinect for XBox 360 sensor.

@benjanowitz

Could you check the “setup” page and see if the sensor is listed there? If not, are you using a USB3 port with the Kinect v2? Those second gen Kinects take immense amounts of USB bandwidth and they may not function properly if the USB port isn’t up to the task.

If the setup page doesn’t list the sensor, try running the sensor program manually and see what it prints:

  • Open the terminal
  • cd /Applications/Delicode_NI_mate.app/Contents/MacOS
  • ./Delicode_Sensor_K4W_libfreenect2 enumerate
  • ./Delicode_Sensor_K4W_libfreenect2 sensor_test
  • include the output from these commands in your response

#13

Hi I am having the same problem, the sensor crashes after about 5 or 6 seconds. Was planning to use it in a presentation on Friday so help would be really most appreciated. Here is what my log looks like:


thanks!


#14

Hello!

Based on the log, I assume you’re using a Kinect for XBox 360 sensor? If it’s the model 1473 I’m afraid you may be out of luck on Mac. The model 1473 should work on Windows, if that’s a possibility for your presentation. Alternatively the model 1414 has a better success rate on Macs.


#15

Ah yes it is a 1473… oh dear. Okay thanks at least I know what the problem is now. I will see what i CAN DO FOR fRIDAY.


#16

Seem to be encountering a similar issue where the xbox 360 v2 isn’t registering in NI-Mate on Sierra…it’s model 1414.

did the tests in Terminal. does this help explain anything? Any other thoughts on how to make it work?

Just upgraded mine to the license as well. Hope we can get this working. Thanks!


#17

The sensor test program you ran was for using the Kinect for XBox One and Kinect for Windows v2 sensors. If you have a Kinect for XBox 360, the program you need to run is Delicode_Sensor_OpenNI. Could you run that one and include the output?


#18

Hey Jesse

Ran that. Attached is the screenshot. Thanks!


#19

Could you run it with the command line argument sensor_test or enumerate?


#20

d’oh. of course. here you go.


#21

Thank you for the tests.

I’m afraid I don’t have a solution at this moment. The library we’re using for XBox 360 sensors is rather outdated which results in some USB related issues on the latest Mac systems. If it’s a possibility using an older MacOS might help with the problem - these issues largely started during / after El Capitan after the MacOS USB system was changed in some drastic ways.