Stuck in splash screen


Hi, i’ve installed NI MATE now with my Kinect 2 on my windows 10 pc. I start it and then a blue screen appear saying “Starting user interface” but then it’s stuck here without messages. (i’ve checked if there were messages under the blue image but nothing, i’ve tryed also to press enter after this image appear but nothing). Can you help me?

NI MATE v2 user interface stuck
User interface is not starting

I moved this in a new topic.

  • Does this also happen if you start NI mate with the sensor unplugged?
  • To be sure, could you hit “enter” when the splash screen gets stuck? This would “ok” some popup that isn’t shown, even though you said there shouldn’t be anything hidden behind the splash screen
  • Does NI mate simply remain in this state, or does it crash?

Something you could try is modifying a few NI mate preferences via regedit:

  • Press Windows key + R, type regedit, hit enter
  • Using the left side of the window, browse to HKEY_CURRENT_USER/Software/Delicode/Delicode NI mate 2/preferences
  • On the right side of the window, double click texture_transfer_gpu and write false in it, then hit ok
  • If this doesn’t help, try changing show_splash_screen to false. This setting doesn’t do anything if you don’t have a license, I think


i’ve installed Delicode NI MATE 2, all went good until i start it.
I run the program and when it shows the blue image with “Starting user interface” the program gets stuck (it’s not doing anything). On my task manager i see that it’s working and responding but i waited 20 minutes and nothing happened. No windows below the image or notification from windows. I’ve already shut down my windows defender and i got no other antivirus. Can you give me help?


PS: Here you can find my latest log


Hi Jesse,

  • yes, i tryed to unplug the sensor but nothing changed.

  • I’ve hit enter but nothing changed, there is no box or message that i can click.

  • Yes it simply remains in this state (working and responding - from the task manager). Also the icon in bottom right screen it’s clickable but it does not show any menus.

I’ve changed the two registry key you told me but everything it’s stuck again, with the difference that now the splash does not appear.

I’ll attach some screen to let you understand better the situation.


Is a problem if i got more screen plugged to my pc?

Also this are my graphics cards:

  • Intel® HD Graphics 630

  • NVIDIA Quadro P2000

are they supported?

kind regards


This is a strange problem.

Both graphics cards should be supported. To verify the GPU isn’t the problem, you could try adding a rule which always launches NI mate using either the Intel or NVidia GPU by entering the NVidia control panel and finding some kind of program specific settings. However, it’s unlikely this is a GPU issue.

Two monitors should work. Something that could happen is that a dialog popup appears on the wrong monitor, somewhere where you don’t notice it.

I’m more inclined to think something in the file system is a problem. Is there anything unusual about the storage where NI mate is installed? Is it a network mount or something like that?

Do you have an antivirus enabled? Could it prevent NI mate from launching?


I’ve already disabled the windows defender, and i got no other antivirus. No, it’s the main disk of my PC (C:). i can try to install it on the other disk (D:). i’ll try to figure out the GPU and i’ll add the rule to verify it. I got three monitor, but no message appear on the screens. I tryed to install it to another machine with 2 monitors and almost same hardware and it works.
I really don’t know why isn’t running.


Is there an older version of ni mate that i can try?


I’ve tryed using ni mate 2.10 but same result


Random idea: does the program launch if you disable your network interface, or perhaps unplug the network cable / disable WLAN?


Nothing changed :frowning: i feel a little frustraded about this :rofl: I can’t figure out what it’s missing or what it’s going wrong. Does the logs helped you?


The only point of note in the log file are there errors with drawing the sensor’s feed. If there are any updates available to your graphics card(s) drivers, try applying them and see if the problem is solved that way.


I still get this issue sometimes (working on Mac) - try just waiting. it usually starts up in 5 or 10 minutes, and then starts up OK for a few months. I don’t know what changes to make it happen again, but maybe 3 or 4 times a year I have to be super patient.


I hope so, i’ll let it open form now on


Still stucked, i’ll let it open for more time but i don’t think this will help


I’ve already updated my graphics card. Nothing changed.

Waited for some hours ahahah but NI MATE wasn’t changing or doing nothing.


I’m afraid I’m out of ideas - if you have a different computer available, try running NI mate on it. This is one of those problems that I haven’t seen earlier, and can only speculate as to what would cause them.


Not your fault man, dunno what it’s going on with my PC. Thanks for the effort, i’ll use another PC.