Why doesn't my Kinect for Xbox 360 work?


#21

heres an update, I tried both the stable and fast versions of the libusb file, and neither of them work, here is the terminal output when i try either one:

progress: initializing device context
progress: USB enumeration
progress: USB open
Error with USB open: Failed to open the USB device!.
progress: enumerating connected devices
Starting live sensor: PrimeSense SensorKinect
progress: creating sensor device
Error with creating sensor device: Failed to open the USB device!.
startlive failed
shutting down sensor

any ideas what is going on with this?


#22

For now we need to get ourselves an installation of El Capitan and investigate the problem at our end. You could attach the output of the command: ioreg -p IOUSB -l -w 0


#23

here is a pastebin, this isnt letting me paste the output here

http://pastebin.com/XzU6UWyD


#24

i tried to post this and got an error, tried to post it with pastebin and a link and got another error (askimet flagged as spam)…can i pm it or send to someone directly?


#25

Thank you for the report.

We’ve managed to reproduce some issues on El Capitan, but the sensors seem to run on our computers, although starting them takes a very long time. We’re still working on the problem.


#26

cool is there any mailing list i can get onto once this is fixed? Also worth noting, i tried this on a mac laptop running (i think) yosemite and had the same problem with it not connecting to the kinects (no pun intended)…whats the system specs of the last stable version for osx?


#27

Hi Benjamin. We don’t have a mailing list for this issue, but you can track this thread for updates on the topic.


#28

ok…what was the last stable/working osx version that worked with v1414 sensors? i can probably install that osx to a boot drive and boot to it/work off of it while i capture?


#29

Currently the best combination is NI mate 2.07 on OS X Yosemite.

We have solved some of the problems on El Capitan, but there’s still some debugging to do.


#30

The Kinect 2 doesn’t show up in the control interface. I’ve tried all port combinations.
Is this likely to also be due to the El Capitan compatibility issues?
I also have a 1414 model that works great (after some initial problems getting the sensor status running)

I’m using El Capitan
Kinect 2
Ni Mate 2.7

iMac (Retina 5K, 27-inch, Late 2015)
4 GHz Intel Core i7
AMD Radeon R9 M395X 4096 M


#31

Unfortunately the Kinect for Windows (2) isn’t currently supported in Mac OS X. Please see this post: https://forum.ni-mate.com/t/what-are-the-differences-between-ni-mate-v1-00-and-v2-00/


#32

Ah ok. I had the V2 sensor working with Daniel Shiffman’s processing sketch with the Capiton OS and wasn’t sure about the NiMate compatibility. I missed the NI Mate 2 faq post you linked to above. FWIW: The 1414 sensor continues to work and I’ll be trying a multi sensor application soon. Thank you for your speedy reply.


#33

Hey, so i tried plugging my 1414 kinect into my macbook pro and running nimate 2.07 and it starts and stops repeatedly, not working still…heres some of the logs, what the heck is going on?

15:38:48: No MIDI ports available for output.
15:39:51: Starting input 1: Kinect for Xbox
15:39:52: Input 1: Live sensor not found.
15:39:52: Input 1: startlive failed
15:39:52: Input 1: shutting down sensor
15:39:52: Input 1 quit normally.
15:39:53: No MIDI ports available for output.
15:39:56: Starting input 1: Kinect for Xbox
15:39:57: Input 1: Live sensor not found.
15:39:57: Input 1: startlive failed
15:39:57: Input 1: shutting down sensor
15:39:57: Input 1 quit normally.


#34

I’m running 10.10.5 on a MacBookPro9,2 by the way


#35

had a little bit of luck on my laptop, one of my kinect sensors is functional, the other one is not…i have a “new” sensor on its way, hopefully this works…


#36

We’ve ran into similar problems on El Capitan (and are trying to fix them in future releases of the software), but we haven’t been able to replicate the issue on 10.10.X as of yet. As I understand you were running 10.11.X previously and have went back to 10.10.5? Did you use Apple’s inbuilt system for the downgrade?


#37

As per NI mate 2.08 you should see some improvement on OS X El Capitan. Please try downloading the new release and report if any success was had.


#38

still isnt working, here is the log:

19:39:02: No MIDI ports available for output.
19:45:55: Starting input 1: Kinect for Xbox
19:45:55: Input 1: xnUSBInit()
19:45:56: No MIDI ports available for output.
19:45:57: Input 1: Error with USB open: Failed to open the USB device!.
19:45:57: Input 1: Starting live sensor: PrimeSense SensorKinect
19:45:57: Input 1: Error with creating sensor device: Failed to open the USB device!.
19:45:57: Input 1: g_context.shutdown
19:45:57: Input 1: sensordevice shutdown
19:45:57: Input 1: startlive failed
19:45:57: Input 1: shutting down sensor
19:45:57: Input 1: g_context.shutdown
19:45:57: Input 1: sensordevice shutdown
19:45:57: Input 1: QFile::remove: Empty or null file name
19:45:57: Input 1 quit normally.
19:46:01: Starting input 1: Kinect for Xbox
19:46:01: Input 1: xnUSBInit()
19:46:03: Input 1: Error with USB open: Failed to open the USB device!.
19:46:03: Input 1: Starting live sensor: PrimeSense SensorKinect
19:46:03: Input 1: Error with creating sensor device: Failed to open the USB device!.
19:46:03: Input 1: g_context.shutdown
19:46:03: Input 1: sensordevice shutdown
19:46:03: Input 1: startlive failed
19:46:03: Input 1: shutting down sensor
19:46:03: Input 1: g_context.shutdown
19:46:03: Input 1: sensordevice shutdown
19:46:03: Input 1: QFile::remove: Empty or null file name
19:46:03: Input 1 quit normally.
19:46:05: No MIDI ports available for output.
19:46:06: Starting input 2: Kinect for Xbox
19:46:06: Input 2: xnUSBInit()
19:46:08: Input 2: Error with USB open: Failed to open the USB device!.
19:46:08: Input 2: Starting live sensor: PrimeSense SensorKinect
19:46:08: Input 2: Error with creating sensor device: Failed to open the USB device!.
19:46:08: Input 2: g_context.shutdown
19:46:08: Input 2: sensordevice shutdown
19:46:08: Input 2: startlive failed
19:46:08: Input 2: shutting down sensor
19:46:08: Input 2: g_context.shutdown
19:46:08: Input 2: sensordevice shutdown
19:46:08: Input 2: QFile::remove: Empty or null file name
19:46:08: Input 2 quit normally.
19:46:14: Starting input 1: Kinect for Xbox
19:46:14: Input 1: xnUSBInit()


#39

Our investigations into this problem continue, but we don’t have a working solution for El Capitan just yet.


#40

Same problem!!! it’s really ennoying.