Why doesn't my Kinect for Xbox 360 work?


#41

Apple did some major changes to the USB stack in El Capitan, which is the source of these problems. If you’re using a Kinect for XBOX 360 and can, we would advice backtracking to 10.10.X until we find a workaround.


#42

I rolled back my os to 10.10.5, and I am still having issues…here is the log, can someone check it out and let me know…

15:29:46: No MIDI ports available for output. 15:33:50: Starting input 1: Kinect for Xbox 15:33:51: Input 1: Live sensor not found. 15:33:51: Input 1: startlive failed 15:33:51: Input 1: shutting down sensor 15:33:51: Input 1: QFile::remove: Empty or null file name 15:33:51: Input 1 quit normally. 15:33:52: No MIDI ports available for output. 15:33:55: Starting input 1: Kinect for Xbox 15:33:56: Input 1: Live sensor not found. 15:33:56: Input 1: startlive failed 15:33:56: Input 1: shutting down sensor 15:33:56: Input 1: QFile::remove: Empty or null file name 15:33:56: Input 1 quit normally. 15:34:07: Starting input 2: Kinect for Xbox 15:34:08: Input 2: Live sensor not found. 15:34:08: No MIDI ports available for output. 15:34:09: Input 2: startlive failed 15:34:09: Input 2: shutting down sensor 15:34:09: Input 2: QFile::remove: Empty or null file name 15:34:09: Input 2 quit normally. 15:34:12: Starting input 2: Kinect for Xbox 15:34:13: Input 2: Live sensor not found. 15:34:14: Input 2: startlive failed 15:34:14: Input 2: shutting down sensor 15:34:14: Input 2: QFile::remove: Empty or null file name 15:34:14: Input 2 quit normally.


#43

hello? anyone there? I did a rollback and still cannot get my kinects to connect…can someone help me please?


#44

As I understand you’re currently unable to run either of the two model 1414 sensors with the latest version of the software? Have you tried with a single sensor at a time?


#45

The Kinect for XBox 360 does not work in USB 3 ports. You will need to connect it to a USB 2 port. Secondly, NI mate does not use the official Microsoft driver. When you install the sensor via NI mate you should get an information box explaining how to install the unsigned driver which the sensor uses with NI mate. If you did this successfully but the sensor still doesn’t work it’s possible the device is using the wrong driver. You can change this from the Windows device manager by switching the driver to the unsigned one for XBox NUI motor and XBox NUI microphone (Or similar name, the sensor also has a microphone that needs to be use the right driver).


#46

Hey Jesse, I installed OS X 10.10.5 onto my 2014 Mac Pro and installed nimate 2.10, and I still cannot connect my Kinect sensors…here is the latest error message below, do you know of anyone who is using a 2014 Mac Pro and able to get nimate working with 1 or 2 Kinect sensors? If so what is their setup/trick to making it work…

15:14:51: No MIDI ports available for output.

15:17:31: Starting input 1: Kinect for Xbox

15:17:31: Input 1: Live sensor not found.

15:17:31: Input 1: startlive failed

15:17:31: Input 1: shutting down sensor

15:17:31: Input 1 quit normally.

15:17:32: No MIDI ports available for output.

15:17:41: Starting input 1: Kinect for Xbox

15:17:42: Input 1: Live sensor not found.

15:17:42: Input 1: startlive failed

15:17:42: Input 1: shutting down sensor

15:17:42: Input 1 quit normally.

15:17:46: Starting input 1: Kinect for Xbox

15:17:47: Input 1: Live sensor not found.

15:17:47: Input 1: startlive failed

15:17:47: Input 1: shutting down sensor

15:17:47: Input 1 quit normally.

15:17:55: Starting input 2: Kinect for Xbox

15:17:55: Input 2: Live sensor not found.

15:17:55: Input 2: startlive failed

15:17:55: Input 2: shutting down sensor

nimate errors

15:17:55: Input 2 quit normally.

15:17:55: No MIDI ports available for output.

15:18:00: Starting input 2: Kinect for Xbox

15:18:00: Input 2: Live sensor not found.

15:18:00: Input 2: startlive failed

15:18:00: Input 2: shutting down sensor

15:18:00: Input 2 quit normally.

15:18:12: Starting input 2: Kinect for Xbox

15:18:12: Input 1: Live sensor not found.

15:18:12: Input 1: startlive failed

15:18:12: Input 1: shutting down sensor

15:18:12: Input 1 quit normally.

15:18:17: Starting input 2: Kinect for Xbox

15:18:17: Input 1: Live sensor not found.

15:18:17: Input 1: startlive failed

15:18:17: Input 1: shutting down sensor

15:18:17: Input 1 quit normally.


#47

I see you’re trying to use two sensors - does using one sensor work? Two sensors can result in some high USB bandwidth usage that may result in errors.


#48

One sensor, two sensors, no sensors, nothing works…not sure but the new Mac pros should be able to that kind of input, right? There’s something not working right with the 2014 mac pros you guys need to troubleshoot, because I don’t think the issue is on my end and I don’t have the resources to buy a whole new computer to accommodate this system right now :frowning:


#49

Hi again Benjamin. Sorry if we’ve asked you this before (I did a quick scan, but was unable to find anything related): Are you plugging in your Kinect to a USB3 slot or a USB2 slot?


#50

hey im plugging it into the usb ports on the new mac, i think they are usb 3.0…i also have a usb port duplicator that i think is legacy/usb 2.0 i can try, but so far its a no-go :frowning:


#51

Hi Benjamin. That’s probably your issue right there. Sorry for not asking before, but the very first post writes about checking that the sensor is connected to a USB2 port (I’m actually updating it right now to state that you have to have a USB2 port).

I’m not sure if the port duplicator/replicator will help here. A thunderbolt hub or something else that has a direct USB2 port might work. Alternatively you might have to get an Asus Xtion Pro Live or similar that does work with USB3.

This limitation comes from the hardware and as much as we’d like to, we can’t really do anything about it.


#53

my 1414 used to work fine with NImate 1.2, but since I upgraded my OS to 10.11.3 El Capitan, its having some difficulties. I tried it with NImate 2.10, but i only have USB3 ports on my MacBookProRetina, so its not working there either.
I’m running a dance/tech workshop in Helsinki next month and would like to have a robust setup for that, so i’m considering upgrading my kit. Can I ask if the Kinect for Xbox One is fully supported in NImate 2? Does it require an external power supply? (like the 1414 does)
thanks,
John


#54

OS X El Capitan is still proving to be a huge problem due to the operating system USB system having been changed. We have a few ideas on how to fix this, but this will take a while. For now using Kinect for XBox 360 on El Capitan is not recommended, and staying in Yosemite is a safer bet.

The Kinect for XBox One / Kinect for Windows v2 sensors are supported on Windows. For now we don’t have an OS X version available as the official SDK only supports Windows. They require an external power supply.

If you’re upgrading your kit you may want to get a graphics card works with Spout (On WIndows) / Syphon (on OS X) for faster performance. Any modern NVidia or AMD GPU should work. Intel GPUs are a gamble, although some of them do work.


#55

Thank you Jesse. My main setup for workshops over the last few years has been 1414 into NImate 1.2, with Syphon and OSC into Isadora (generating projected visuals and sending MIDI CC into Ableton Live to tweak sounds)
It looks like i’ll be going back to using a 2D IR camera for a while until these problems get ironed out.


#56

can anybody help me about this problem ? when I wan’t to record animation with kinect, my sensor is error. thank you for your attention


#57

Er, that definitely seems like a bug. :confused:

I can think of two possible reasons for it. The first one was a bug that was fixed for the upcoming release, but this seems more like the USB device having some problems. To make sure, which sensor device are you using? You mentioned Kinect, but NI mate is clearly making OpenNI 2 sensors (XTions?).

  • If it’s a Kinect, is it plugged in a USB 2 port?
  • If it’s a XTion, does it have the upgraded firmware to run in USB 3? If not, make sure to USB 2. If yes, make sure to use USB 3.

EDIT: Just to be sure it’s not the second issue I’m suspecting, could you run the sensor test program?

  • Open the command prompt (windows key + r, type cmd, hit enter)
  • Go in the NI mate install directory: cd “c:/Program Files/Delicode/NI mate 2” or similar, based on where you installed NI mate
  • Go in the sensor program folder: cd Delicode_Sensor_OpenNI2 or similar folder.
  • Run the test: Delicode_Sensor_OpenNI2.exe sensor_test
  • Attach the output here

#58

Hi Ni Mate
I am not able to connect my Kinect with ni mate (ONE neither 360). I’m on window 10 and I never see the PrimeSense label in the device manager.
Just don’t know where is my error.
Can you tell me where I am wrong?


#59


#60

Hello!

The Xbox One should work after installing the official drivers on Windows 10, but the 360 requires that you have the unsigned driver installed. You can see the instructions for this in this reply: Why doesn't my Kinect for Xbox 360 work?

Is the sensor connected to a USB 2 port?


#61

Feeling a little overwhelmed. A few years ago I was using kinects on both my mac and PC, using a variety of programs. Ni Mate and Vizakord, & Z Vector no longer work on either my PC or MAC, tested on 2 different XBOX 360 Kinects, and 1 Kinect 2. On the Mac both Kinects are no longer detected on 4 different Kinect programs that previously worked. On the PC neither Kinect 1 or 2 is detected in either NiMate or Z-Vector, or Vizakord. I have downloaded older versions of NImate with the same results. All of these have the same reaction- the kinect lights up with a flashing green light when plugged in- and the program does not detect the Kinect. On the PC running WIn 10- Win 3d studio will open and I can scan with it fine- all other kinect programs do not detect anything. Under device manager on PC I see only Kinect motor NIU as connected. I downloaded drivers with permissions disabled as described. I have tried every USB port with the same result on both computers. I have an installation in 2 weeks I am building out and I took it for granted that the Kinect software would still work. I last ran Vizakord and Z-Vector a few months ago and they worked great- they now also do not work. I have looked at the troubleshooting for NiMate and I seem to be out of options.