[win 10] Face Analysis tracking causes kinnect v2 to crash


#1

Windows 10 home (64 bit)
kinnect v2
2x usb 3.0 ports on a ASrock 870 Exreme3 R2.0 ATX Motherboard (a bit dated)
gtx 1060 6gb

To preface this; all other tracking methods, as far as I can tell, work and do connect to blender. I have made sure that Libfreenect2 is off and that default usb 3 mode is on

Whenever I try to turn on face analysis when a body is detected, the kinect sensor crashes.

opening the dump file in Visual studio the exception ifo states: the thread tried to execute an invalid instruction

Log states:

17:08:39: New user 1
17:08:43: Input 1: starting face tracking for user2
17:08:43: Input 1 crashed (view crash report)
17:08:43: Process crashed
17:08:43: Input 1 error: sensor crashed.
17:08:43: Input 1 crashed with exit code -1073741795.

any help would be appreciated


#2

Hello!

Could you open the NI mate crash reporter (in NI mate’s directory) and browse to a crash report that’s for the sensor program? Select the latest one by date. Upload that one and we’ll take a look at it.


#3

I sent it, thank you for your time!


#4

I’m looking at the crash report. The reason for the crash is “illegal instruction” inside Kinect20.Face.dll, something I’ve yet to see reported earlier. Typically illegal instructions happen if the hardware or drivers don’t support some operation that the program tries to execute - most commonly caused by the processor not supporting some acceleration technology.

The crash reporter failed to identify your Windows version. Could you tell me a bit about your hardware?


#5

[for other people’s sake]

My hardware is

MB:
AsRock- 870 Extreme3 R2.0 ATX AM3+ Motherboard
CPU:
AMD Phenom II X4 955 (3.2GHZ quad)
Ram:
8.0 GB of G.Skill ram (not too sure about specifics)
GPU:
GTX 1060 6GB edition.
OS:
Windows 10 64 bit upgraded from windows 7 Via win 8

Thank you for your time again.If you would like I can reproduce the crash or send over another crash report.